jQuery2.0发布—响应式设计进入新阶段?

jQuery开发团队在今年年初发布了jQuery 1.9正式版本和jQuery 2.0 beta版本。

兼顾移动设备? 能有多少脚本能够流畅的运行在移动设备之上?

众所周知的jQuery ,在网站开发中,具有非常强大的优势,体积小,运行速度快,代码精简,已经成为众多网站开发所必备的脚本之一。在响应式的网站设计中,jQuery 对移动设备(触屏设备,区别于鼠标点击,而是手指的滑动,点击)支持并不是非常的好,很多在桌面电脑上能够非常流畅实现的代码,在移动设备中的表现都不佳,这就代表着,开发响应式设计,在移动设备上,我们需要运行另一套使用的脚本—jQuery Mobile,重新书写兼顾移动设备的脚本,这对于小型网站来说,提高了他们的开发成本,因为他们所需要的只是一些细节的,小的动画效果。

这次所发布的jQuery 1.9正式版本和jQuery 2.0 beta,明确表示了jQuery 2.0将兼顾移动设备,那就让我们拭目以待,进行新的测试,看看我们的jQuery能够在多大程度上给移动设备添砖加瓦把!

jQuery2.0真的不支持IE?

在百度搜索jQuery 2.0,几乎所有的消息都在指出,jQuery 2.0不再支持 ie6/ie7/ie8,我们想一下,如果jQuery2.0真的不支持IE6/7/8,这肯定是一个非常疯狂的决定,ie用户不仅在中国,在全世界的范围内的用户都是非常庞大的,国外著名的主题站主题森林(themeforest)上,大部分的主题都表明了经过ie6/ie7/ie8的测试,不做ie的兼容,等于放弃了一个巨大的用户群体,所以,无疑这条消息的表达并不完整,容易带给人以误解。

jQuery2.0是说不再支持IE6/7/8中特有的功能,比如borked event model, IE7 “attroperties”, HTML5 shims等。所不支持的只是一些特性而已,并不等于不支持浏览器,并且还可以加一段代码解决这一问题。作为jQuery开发者,你总不能为了用2.0而放弃IE用户吧,并且感觉jQuery2.0对IE造成的影响并不会很大,用户才是上帝,你不可能让用户去改变原有的浏览器,你能做的只是去适应用户。

 

结语:jQuery2.0的发布的确是一条振奋的消息,所有对于他的功能猜测和期待将在我们实际工作中的使用才能够更加准确的判定。

上一篇:

下一篇:

如未标明出处,所有文章均为WEB主题公园原创,如需转载,请附上原文地址,感谢您的支持和关注。

本文地址:https://www.themepark.com.cn/jquery20fb-xyssjjrxjd.html

WordPress原创主题,高端网站模板建站,网站模板建站资源以及开发知识分享,尽在WEB主题公园
WEB主题公园致力于开发适合中国人习惯的中文WordPress网站模板,并提供全程视频教程,让您能够轻松的使用网站模板建立好自己的网站!

相关文章

文章评论

您好!请登录

取消回复

    个人中心我的

    联系我们x

    联系我们,从qq在线客服,电话和邮件

    售前客服-1[点击对话]

    购买之前想要了解和咨询

    售前客服-2[点击对话]

    购买之前想要了解和咨询

    售后客服[售后支持]

    购买后输入订单号加好友

    咨询热线:0731-8578 7193

    联系邮箱:
    info@themepark.com.cn

    请注意:在线客服以及咨询热线请在 工作日的9:30~18:00来电咨询 电子邮件在任何时间都会回复

    客服
    回到顶部 顶部